Coudn't run windows version: couldn't load library

Frequently Asked Questions

Coudn't run windows version: couldn't load library

Postby Googie » Wed Jul 27, 2011 9:14 pm

A bug report

Repeatable: yes

Description:
---------------------------
Error in startup script
---------------------------
couldn't load library "D:/Загрузки/sqlitestudio-2.0.5.exe/lib/itcl3.4/itcl34.dll": this library or a dependent library could not be found in library path
while executing
"load D:/Загрузки/sqlitestudio-2.0.5.exe/lib/itcl3.4/itcl34.dll Itcl"
("package ifneeded Itcl 3.4" script)
invoked from within
"package require Itcl 3.3"
invoked from within
"set ::PKG(Itcl) [package require Itcl 3.3]"
(file "D:/Загрузки/sqlitestudio-2.0.5.exe/lib/sqlitestudio/main.tcl" line 172)
invoked from within
"source D:/Загрузки/sqlitestudio-2.0.5.exe/lib/sqlitestudio/main.tcl"
("package ifneeded sqlitestudio 2.0.5" script)
invoked from within
"package require sqlitestudio"
(file "D:/Загрузки/sqlitestudio-2.0.5.exe/main.tcl" line 6)
Googie
Site Admin
 
Posts: 773
Joined: Wed Jul 27, 2011 8:04 pm

Re: Coudn't run windows version: couldn't load library

Postby Googie » Wed Jul 27, 2011 9:15 pm

From manual:
Directory name
Binary distribution is sensitive to strange characters in it's path. It's know that some specific unicode characters cause problems with running SQLiteStudio. An example would be (under Windows):
C:\Users\some_user\Рабочий стол\sqlitestudio-2.0.5.exe
Running binary from that place will fail. The problem is these Russian characters here. Please avoid such situations and you should have no problems.
Link: http://sqlitestudio.one.pl/docs/html/ma ... 1301410993

So, move your exec into directory with no Russian characters and you should be ok.
Googie
Site Admin
 
Posts: 773
Joined: Wed Jul 27, 2011 8:04 pm


Return to FAQ

Who is online

Users browsing this forum: No registered users and 1 guest